AltME: R3 Protocols

Messages

GrahamC
Looks like module handling has changed since I wrote this.
Bo has been using this ... Bo?
GrahamC
Just tried it and I don't get that error.  Are you using latest rebol3 ?

Luis
Version:   2.101.0.3.1
  Platform:  Windows win32-x86
  Build:     14-Aug-2013/14:51:03
>> do %prot-ftp.r
>> cmd: open ftp://user:pw@majorityreporttv.com
port opened ...
>>
amacleod
Version:   2.101.0.3.1
Platform:  Windows win32-x86
Build:     14-Aug-2013/14:51:03

>> do %prot-ftp.r3
Module: "Rebol 3 FTP scheme" Version: 0.0.92 Date: 10-Jan-2010 24-Feb-2013
>> cmd: open ftp://user:pw@majorityreporttv.com
** Script error: net-log word is not bound to a context
** Where: open
** Near: open ftp://user:pw@majorityreporttv.com
Version:   2.101.0.3.1
Platform:  Windows win32-x86
Build:     14-Aug-2013/14:51:03
GrahamC
>> rebol/version
== 3.0.0.3.1
>> do %prot-ftp.reb
Module: "Rebol 3 FTP scheme" Version: 0.0.92 Date: 10-Jan-2010 24-Feb-2013
>> cmd: open ftp://user:pw@majorityreporttv.com
port opened ...
You're using an ancient version of Rebol3
Download latest from rebolsource.net
amacleod
Version:   2.101.0.3.1
Platform:  Windows win32-x86
Build:     4-Mar-2014/4:53:51
Same version#???
Same error too....
>> do %prot-ftp.r3
Module: "Rebol 3 FTP scheme" Version: 0.0.92 Date: 10-Jan-2010 24-Feb-2013
>> cmd: open ftp://majorityreporttv.com
** Script error: net-log word is not bound to a context
** Where: open
** Near: open ftp://majorityreporttv.com

GrahamC
Then I don't know because it works for me and others
DideC
Try to put R3 in a different folder and try again.
Or maybe your prot-ftp file has been modify in some way?
Kaj
Isn't 3.0 the Atronix version?
2.101 is the official or community version
GrahamC
Yes, Atronix version ... but everyone else is using different versions and it works
Kaj
Well, Alan's version is not ancient

GrahamC
The times I have seen this _not bound to a context_ error is I think when something has not been defined as a local in module before it is then used.
Alan's first version he was using was from Aug 2013 which is pretty old is it not?
Kaj
Hardly ancient I would say
GrahamC
Do you have any suggestions as to why he is getting this error?

Last message posted 146 weeks ago.