AltME: SDK

Messages

Maxim
>> exists? %license.key
== true
' 8-/
Kaj
Perhaps .rebol/ ?
Maxim
I think its the license itself.  Looks like its keyed to the platform.
I was certain I had a linux version of the license.  maybe not.

ddharing
I had a similar problem before. I was using the wrong license file.
Maxim
hi guys.   Since its not obvious I can still purchase a license of the SDK, I'm wondering if someone can share his Linux license with me.
I've got to encap stuff for Linux and it seems my SDK license doesn't work on linux.
Private Message me, if you've got a license you can lend me... thanks!!!

Marco
@Maxim For "encap stuff for Linux" you mean build a self-extracting executable or something more complex?

Maxim
I need to encap some of my server software on linux.

Marco
If someone is interested in a rebol-red/system program that does on Linux what XPackerX does on Windows, let me know.  I am not releasing it to the public since the code is not  "clean" and probably you have to tweak it a little.

NickA
Marco, I'd love to see that.

amacleod
I think I have an old version of the sdk. I see on the website a new version including command came out in 2010...I can't believe I never noticed this but I just tried packaged script that reads an htttps page which errors out. I assume that https was added to sdk at that time because current rebol view runs script fine.
Any way to get this sdk as the links are dead.
Also, it says the upgrade is free for those that purchased sdk within the year which I believe is my case...think that still is valid?

Maxim
everything related to the SDK seems to be dead.  I wish Carl just posted a public key with a download page for each supported platform.  they are getting outdated anyways, so they're not as cutting edge as they used to be.
Gregg
The king is dead, long live the king?

james_nak
It's been a real long time since I've compiled anything but for some reason my latest script and even older scripts produce this error when I click on the .exe file. Any ideas?
** Script Error: Cannot use path on none! value
** Where: insert-event-func
** Near: insert system/view/screen-face/feel/event-funcs :funct
:funct
** Press enter to quit...
The weirdness is that I have .exe files that I encapped previously that work perfectlt but when I tried to check to see if I encap them again,  they produce this error.
Endo
Possible reasons are:
1. You encap with 2.7.7, better to use 2.7.8.
2. You encap with an encapper which has no View capabilities, better to use encmdview.
3. The were some functions in your let's say rebol.r or user.r file which you #include, but now those files are changed and there are some missing functions.
james_nak
Thank you so much for your response Endo. This is such a mystery. I even get this with a one-line view statement (though it is tied to view in some way; a "hello world" to the console works). I've done all 3 of your suggestions including going back to 2.7.7 just to test. I can't figure out what it could be (obviously!) since I haven't changed anything to my knowledge. You know, it's old stuff that used to encap besides the simplicity of the one-liner test and the new app I originally tried. Anyway, I'll keep at it. Thanks.
james_nak
Dumb Dumb Dumb! I must have deleted the encmdview.exe tool.  You were right Endo (#2) I forgot there was a distinction between the encmd and the view one and since it was missing I didn't put 2 and 2 together. Luckily I saved the sdk zip files. Thanks, your answer spurred my thoughts.

Endo
You are welcome, glad it helped.

Last message posted 49 weeks ago.