AltME: R3-GUI

Messages

ddharing
That's a good suggestion. I'll pass it along to Shixin.

Bo
Do you know when 'load-gui will be working again?

ddharing
It should have already been fixed. Sorry. It will be working tomorrow even if I have to do it myself.
Bo
Thanks David!

ddharing
Bo, we have a temporary workaround for the load-gui issue ahead of a more permanent fix.
To give you a little background, we migrated our main website to Squarespace which doesn't allow direct access to the directory. This means that we can't host individual files from Squarespace. The only workaround for this is to create a URL mapping in Squarespace to point to our old 1&1 server. Unfortunately, Rebol3's HTTP protocol does not support redirects. So, because of a combination of Squarespace and Rebol3 limitations, we don't have a clean solution.
The temporary workaround is to download the Atronix version of r3-gui.r3 from this URL: http://s293761966.onlinehome.us/r3/r3-gui.r3. In your script, "do" this file instead of using load-gui.
We are in the process of creating a new sub domain (rebol.atronixengineering.com) and will release new builds of Rebol which will point there. Additionally, we plan to make the download optional -- if there is no local file.

Bo
OK. That seems to work. But I wonder if something changed. My script that used to work is now giving me the following error:
REBOL Host Failure:
Parent window can't be found
ddharing
That is strange. I just looked at the source for load-gui. I don't see how that could be happening.
BTW, the new subdomain is working. The new URL is http://rebol.atronixengineering.com/r3/r3-gui.r3.
Robert
Bo, are you sure you use the right R3 version?
Bo
I just downloaded it from Atronix.
ddharing
Bo, I just posted the new binaries with updated URLs. Please go to http://www.atronixengineering.com/downloads.

Bo
It works!

Pekr
Robert - R3 GUI docs on the saphirion domain are not displayed, some error is displayed: Agreeing to the Xcode/iOS license requires admin privileges, please re-run as root via sudo. 0

Maarten
ddharing - the production releases are plain text, no links?
Gregg
I noticed that too, and pulled the dev release, but I also wanted to thank all the Redbol teams that are moving things forward. I hope to surface again before too long and contribute.
Robert
Pekr, thanks... that's such a damnd stupid thing Apple is doing. They update a CLI tool that needs me to press a key as SU... what the hell are they thinking?
Should work again...
Pekr
:-)

ddharing
Maarten / Gregg: Yes, just the dev links are active for now. It's the build that we're using internally. Please let us know if you have any issues.
Actually, we're using a slightly newer one because a few days ago we found a bug that prevented the use of a Mac as an X-terminal to Linux (i.e. X over SSH). That is fixed and the link will be updated soon. We tested using El Capitan and XQuartz 2.7.8 on the Mac.

GiuseppeC
Hi,
  finally I have managed to open my first GUI using R3-GUI from Saphirion.  It is "only" a view on my company database which returns open orders.
My first thanks go to Nick Antonaccio for his guide and Ashley for his fantastic munge.

Last message posted 13 weeks ago.